<!DOCTYPE html>
<html lang="en-US">
<head>
	<meta charset="UTF-8" />
	<meta http-equiv="X-UA-Compatible" content="IE=10" />
	<link rel="profile" href="http://gmpg.org/xfn/11" />
	<link rel="pingback" href="https://ilovethepromise.com/xmlrpc.php" />
	<title>For Father&#8217;s Day&#8230;.really? &#8211; The Promise</title>
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//maxcdn.bootstrapcdn.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="The Promise &raquo; Feed" href="https://ilovethepromise.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="The Promise &raquo; Comments Feed" href="https://ilovethepromise.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="The Promise &raquo; For Father&#8217;s Day&#8230;.really? Comments Feed" href="https://ilovethepromise.com/uncategorized/for-fathers-day-really/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.2.1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.2.1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/ilovethepromise.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=bb3be932eefd63a1ab9e576dfbee964a"}};
			!function(a,b,c){function d(a){var b,c,d,e,f=String.fromCharCode;if(!k||!k.fillText)return!1;switch(k.clearRect(0,0,j.width,j.height),k.textBaseline="top",k.font="600 32px Arial",a){case"flag":return k.fillText(f(55356,56826,55356,56819),0,0),!(j.toDataURL().length<3e3)&&(k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57331,65039,8205,55356,57096),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57331,55356,57096),0,0),c=j.toDataURL(),b!==c);case"emoji4":return k.fillText(f(55357,56425,55356,57341,8205,55357,56507),0,0),d=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55357,56425,55356,57341,55357,56507),0,0),e=j.toDataURL(),d!==e}return!1}function e(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g,h,i,j=b.createElement("canvas"),k=j.getContext&&j.getContext("2d");for(i=Array("flag","emoji4"),c.supports={everything:!0,everythingExceptFlag:!0},h=0;h<i.length;h++)c.supports[i[h]]=d(i[h]),c.supports.everything=c.supports.everything&&c.supports[i[h]],"flag"!==i[h]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[i[h]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='dashicons-css'  href='https://ilovethepromise.com/wp-includes/css/dashicons.min.css?ver=bb3be932eefd63a1ab9e576dfbee964a' type='text/css' media='all' />
<link rel='stylesheet' id='wunderground-css'  href='https://ilovethepromise.com/wp-content/plugins/wunderground/assets/css/wunderground.css?ver=2.1.3' type='text/css' media='all' />
<link rel='stylesheet' id='cff-css'  href='https://ilovethepromise.com/wp-content/plugins/custom-facebook-feed/css/cff-style.css?ver=2.4.5' type='text/css' media='all' />
<link rel='stylesheet' id='cff-font-awesome-css'  href='https://maxcdn.bootstrapcdn.com/font-awesome/4.5.0/css/font-awesome.min.css?ver=4.5.0' type='text/css' media='all' />
<link rel='stylesheet' id='feedzy-rss-feeds-css'  href='https://ilovethepromise.com/wp-content/plugins/feedzy-rss-feeds/css/feedzy-rss-feeds.css?ver=3.1.0' type='text/css' media='all' />
<link rel='stylesheet' id='vantage-style-css'  href='https://ilovethepromise.com/wp-content/themes/vantage/style.css?ver=2.6' type='text/css' media='all' />
<link rel='stylesheet' id='font-awesome-css'  href='https://ilovethepromise.com/wp-content/themes/vantage/fontawesome/css/font-awesome.css?ver=4.6.2' type='text/css' media='all' />
<link rel='stylesheet' id='siteorigin-mobilenav-css'  href='https://ilovethepromise.com/wp-content/themes/vantage/inc/mobilenav/css/mobilenav.css?ver=2.6' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='https://ilovethepromise.com/wp-content/plugins/jetpack/css/jetpack.css?ver=4.9' type='text/css' media='all' />
<script type='text/javascript' src='https://ilovethepromise.com/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='https://ilovethepromise.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='https://ilovethepromise.com/wp-includes/js/jquery/ui/core.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://ilovethepromise.com/wp-includes/js/jquery/ui/widget.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://ilovethepromise.com/wp-includes/js/jquery/ui/position.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://ilovethepromise.com/wp-includes/js/jquery/ui/menu.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://ilovethepromise.com/wp-includes/js/wp-a11y.min.js?ver=bb3be932eefd63a1ab9e576dfbee964a'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var uiAutocompleteL10n = {"noResults":"No results found.","oneResult":"1 result found. Use up and down arrow keys to navigate.","manyResults":"%d results found. Use up and down arrow keys to navigate.","itemSelected":"Item selected."};
/* ]]> */
</script>
<script type='text/javascript' src='https://ilovethepromise.com/wp-includes/js/jquery/ui/autocomplete.min.js?ver=1.11.4'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var WuWidget = {"apiKey":"3ffab52910ec1a0e","_wpnonce":"02e17a6db3","ajaxurl":"https:\/\/ilovethepromise.com\/wp-admin\/admin-ajax.php","is_admin":"","subdomain":"www"};
/* ]]> */
</script>
<script type='text/javascript' src='https://ilovethepromise.com/wp-content/plugins/wunderground/assets/js/widget.min.js?ver=2.1.3'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var samAjax = {"ajaxurl":"https:\/\/ilovethepromise.com\/wp-content\/plugins\/simple-ads-manager\/sam-ajax.php","loadurl":"https:\/\/ilovethepromise.com\/wp-content\/plugins\/simple-ads-manager\/sam-ajax-loader.php","load":"","mailer":"1","clauses":"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","doStats":"1","container":"sam-container","place":"sam-place","ad":"sam-ad"};
/* ]]> */
</script>
<script type='text/javascript' src='https://ilovethepromise.com/wp-content/plugins/simple-ads-manager/js/sam-layout.min.js?ver=2.9.8.125'></script>
<script type='text/javascript' src='https://ilovethepromise.com/wp-content/themes/vantage/js/jquery.flexslider.min.js?ver=2.1'></script>
<script type='text/javascript' src='https://ilovethepromise.com/wp-content/themes/vantage/js/jquery.touchSwipe.min.js?ver=1.6.6'></script>
<script type='text/javascript' src='https://ilovethepromise.com/wp-content/themes/vantage/js/jquery.theme-main.min.js?ver=2.6'></script>
<script type='text/javascript' src='https://ilovethepromise.com/wp-content/themes/vantage/js/jquery.fitvids.min.js?ver=1.0'></script>
<!--[if lt IE 9]>
<script type='text/javascript' src='https://ilovethepromise.com/wp-content/themes/vantage/js/html5.min.js?ver=3.7.3'></script>
<![endif]-->
<!--[if (gte IE 6)&(lte IE 8)]>
<script type='text/javascript' src='https://ilovethepromise.com/wp-content/themes/vantage/js/selectivizr.min.js?ver=1.0.2'></script>
<![endif]-->
<script type='text/javascript'>
/* <![CDATA[ */
var mobileNav = {"search":"","text":{"navigate":"Menu","back":"Back","close":"Close"},"nextIconUrl":"https:\/\/ilovethepromise.com\/wp-content\/themes\/vantage\/inc\/mobilenav\/images\/next.png","mobileMenuClose":"<i class=\"fa fa-times\"><\/i>"};
/* ]]> */
</script>
<script type='text/javascript' src='https://ilovethepromise.com/wp-content/themes/vantage/inc/mobilenav/js/mobilenav.min.js?ver=2.6'></script>
<link rel='https://api.w.org/' href='https://ilovethepromise.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://ilovethepromise.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://ilovethepromise.com/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='California pays a lot for recycling&#8230;.only&#8230;..' href='https://ilovethepromise.com/uncategorized/california-pays-a-lot-for-recycling-only/' />

<link rel="canonical" href="https://ilovethepromise.com/uncategorized/for-fathers-day-really/" />
<link rel='shortlink' href='https://wp.me/p71IXf-gn' />
<link rel="alternate" type="application/json+oembed" href="https://ilovethepromise.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Filovethepromise.com%2Funcategorized%2Ffor-fathers-day-really%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://ilovethepromise.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Filovethepromise.com%2Funcategorized%2Ffor-fathers-day-really%2F&#038;format=xml" />


<!-- Plugin: Open external links a new window. Plugin by Kristian Risager Larsen, http://kristianrisagerlarsen.dk . Download it at http://wordpress.org/extend/plugins/open-external-links-in-a-new-window/ -->
<script type="text/javascript">//<![CDATA[
	function external_links_in_new_windows_loop() {
		if (!document.links) {
			document.links = document.getElementsByTagName('a');
		}
		var change_link = false;
		var force = '';
		var ignore = '';

		for (var t=0; t<document.links.length; t++) {
			var all_links = document.links[t];
			change_link = false;
			
			if(document.links[t].hasAttribute('onClick') == false) {
				// forced if the address starts with http (or also https), but does not link to the current domain
				if(all_links.href.search(/^http/) != -1 && all_links.href.search('ilovethepromise.com') == -1) {
					// alert('Changeda '+all_links.href);
					change_link = true;
				}
					
				if(force != '' && all_links.href.search(force) != -1) {
					// forced
					// alert('force '+all_links.href);
					change_link = true;
				}
				
				if(ignore != '' && all_links.href.search(ignore) != -1) {
					// alert('ignore '+all_links.href);
					// ignored
					change_link = false;
				}

				if(change_link == true) {
					// alert('Changed '+all_links.href);
					document.links[t].setAttribute('onClick', 'javascript:window.open(\''+all_links.href+'\'); return false;');
					document.links[t].removeAttribute('target');
				}
			}
		}
	}
	
	// Load
	function external_links_in_new_windows_load(func)
	{	
		var oldonload = window.onload;
		if (typeof window.onload != 'function'){
			window.onload = func;
		} else {
			window.onload = function(){
				oldonload();
				func();
			}
		}
	}

	external_links_in_new_windows_load(external_links_in_new_windows_loop);
	//]]></script>

<script type="text/javascript">
(function(url){
	if(/(?:Chrome\/26\.0\.1410\.63 Safari\/537\.31|WordfenceTestMonBot)/.test(navigator.userAgent)){ return; }
	var addEvent = function(evt, handler) {
		if (window.addEventListener) {
			document.addEventListener(evt, handler, false);
		} else if (window.attachEvent) {
			document.attachEvent('on' + evt, handler);
		}
	};
	var removeEvent = function(evt, handler) {
		if (window.removeEventListener) {
			document.removeEventListener(evt, handler, false);
		} else if (window.detachEvent) {
			document.detachEvent('on' + evt, handler);
		}
	};
	var evts = 'contextmenu dblclick drag dragend dragenter dragleave dragover dragstart drop keydown keypress keyup mousedown mousemove mouseout mouseover mouseup mousewheel scroll'.split(' ');
	var logHuman = function() {
		var wfscr = document.createElement('script');
		wfscr.type = 'text/javascript';
		wfscr.async = true;
		wfscr.src = url + '&r=' + Math.random();
		(document.getElementsByTagName('head')[0]||document.getElementsByTagName('body')[0]).appendChild(wfscr);
		for (var i = 0; i < evts.length; i++) {
			removeEvent(evts[i], logHuman);
		}
	};
	for (var i = 0; i < evts.length; i++) {
		addEvent(evts[i], logHuman);
	}
})('//ilovethepromise.com/?wordfence_logHuman=1&hid=E06919E38779FC8917010D11FA337FFA');
</script>
<link rel='dns-prefetch' href='//v0.wordpress.com'>
<style type='text/css'>img#wpstats{display:none}</style><meta name="viewport" content="width=device-width, initial-scale=1" />		<style type="text/css">
			.so-mobilenav-mobile + * { display: none; }
			@media screen and (max-width: 480px) { .so-mobilenav-mobile + * { display: block; } .so-mobilenav-standard + * { display: none; } }
		</style>
	
<!-- Jetpack Open Graph Tags -->
<meta property="og:type" content="article" />
<meta property="og:title" content="For Father&#8217;s Day&#8230;.really?" />
<meta property="og:url" content="https://ilovethepromise.com/uncategorized/for-fathers-day-really/" />
<meta property="og:description" content="Dear Lord, please take me now&#8230;..I am a Father and appreciate whatever gift my children feel is best for me on Father&#8217;s Day&#8230;except for this.  First, I do not look anything like the…" />
<meta property="article:published_time" content="2017-05-17T00:59:46+00:00" />
<meta property="article:modified_time" content="2017-05-17T00:59:46+00:00" />
<meta property="og:site_name" content="The Promise" />
<meta property="og:image" content="https://ilovethepromise.com/wp-content/uploads/2017/05/Romphim.png" />
<meta property="og:image:width" content="680" />
<meta property="og:image:height" content="452" />
<meta property="og:locale" content="en_US" />
<meta name="twitter:image" content="https://ilovethepromise.com/wp-content/uploads/2017/05/Romphim.png?w=640" />
<meta name="twitter:card" content="summary_large_image" />
	<style type="text/css" media="screen">
		#footer-widgets .widget { width: 100%; }
		#masthead-widgets .widget { width: 100%; }
	</style>
	<style type="text/css" id="customizer-css">#masthead .hgroup h1, #masthead.masthead-logo-in-menu .logo > h1 { font-size: 30px; color: #000000 } .entry-content, #comments .commentlist article .comment-meta a { color: #000000 } #masthead .hgroup { padding-top: 2px; padding-bottom: 2px } .entry-content a:hover, .entry-content a:focus, .entry-content a:active, #secondary a:hover, #masthead .hgroup a:hover, #masthead .hgroup a:focus, #masthead .hgroup a:active, .comment-form .logged-in-as a:hover, .comment-form .logged-in-as a:focus, .comment-form .logged-in-as a:active { color: #f2ee13 } .main-navigation ul { text-align: center } .main-navigation ul li a { padding-top: 0px; padding-bottom: 0px } .main-navigation ul li a, #masthead.masthead-logo-in-menu .logo { padding-left: 20px; padding-right: 20px } .main-navigation ul li { font-size: 20px } a.button, button, html input[type="button"], input[type="reset"], input[type="submit"], .post-navigation a, #image-navigation a, article.post .more-link, article.page .more-link, .paging-navigation a, .woocommerce #page-wrapper .button, .woocommerce a.button, .woocommerce .checkout-button, .woocommerce input.button, #infinite-handle span button { text-shadow: none } a.button, button, html input[type="button"], input[type="reset"], input[type="submit"], .post-navigation a, #image-navigation a, article.post .more-link, article.page .more-link, .paging-navigation a, .woocommerce #page-wrapper .button, .woocommerce a.button, .woocommerce .checkout-button, .woocommerce input.button, .woocommerce #respond input#submit.alt, .woocommerce a.button.alt, .woocommerce button.button.alt, .woocommerce input.button.alt, #infinite-handle span { -webkit-box-shadow: none; -moz-box-shadow: none; box-shadow: none } #main { background-color: #f9f9f9 } #colophon, body.layout-full { background-color: #122c87 } #footer-widgets .widget { color: #0a0b42 } #colophon .widget_nav_menu .menu-item a { border-color: #0a0b42 } </style><link rel="icon" href="https://ilovethepromise.com/wp-content/uploads/2017/04/cropped-The-Promise-Site-Logo-32x32.png" sizes="32x32" />
<link rel="icon" href="https://ilovethepromise.com/wp-content/uploads/2017/04/cropped-The-Promise-Site-Logo-192x192.png" sizes="192x192" />
<link rel="apple-touch-icon-precomposed" href="https://ilovethepromise.com/wp-content/uploads/2017/04/cropped-The-Promise-Site-Logo-180x180.png" />
<meta name="msapplication-TileImage" content="https://ilovethepromise.com/wp-content/uploads/2017/04/cropped-The-Promise-Site-Logo-270x270.png" />
			<link rel="stylesheet" type="text/css" id="wp-custom-css" href="https://ilovethepromise.com/?custom-css=d3a972a841" />
		</head>

<body class="post-template-default single single-post postid-1015 single-format-standard wp-custom-logo do-etfw responsive layout-full no-js no-sidebar panels-style-force-full page-layout-default mobilenav">


<div id="page-wrapper">

	
	
		<header id="masthead" class="site-header" role="banner">

	<div class="hgroup full-container ">

		
			<a href="https://ilovethepromise.com/" title="The Promise" rel="home" class="logo"><img src="https://ilovethepromise.com/wp-content/uploads/2017/04/The-Promise-Logo-1.png"  class="logo-height-constrain"  width="279"  height="140"  alt="The Promise Logo"  srcset="https://ilovethepromise.com/wp-content/uploads/2017/04/The-Promise-Logo-1.png 2x"  /></a>
			
				<div id="header-sidebar" class="no-logo-overlay">
					<aside id="text-6" class="widget widget_text">			<div class="textwidget"><center><strong><h1><a href="http://radio.securenetsystems.net/radio_player_large.cfm?stationCallSign=WMUV" target="_blank">LISTEN  <i class="fa fa-microphone"></i>  LIVE</a></h1><center></div>
		</aside>				</div>

			
		
	</div><!-- .hgroup.full-container -->

	
<nav role="navigation" class="site-navigation main-navigation primary use-sticky-menu">

	<div class="full-container">
				
					<div id="so-mobilenav-standard-1" data-id="1" class="so-mobilenav-standard"></div><div class="menu-promise-menu-container"><ul id="menu-promise-menu" class="menu"><li id="menu-item-811" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-811"><a href="https://ilovethepromise.com/">HOME PAGE</a></li>
<li id="menu-item-810" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-810"><a href="https://ilovethepromise.com/on-air/">ON AIR</a>
<ul class="sub-menu">
	<li id="menu-item-826" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-826"><a target="_blank" href="https://ilovethepromise.com/kevin-taylor/">Kevin &#038; Taylor</a></li>
	<li id="menu-item-825" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-825"><a href="https://ilovethepromise.com/life-with-lisa-williams/">Life with Lisa Williams</a></li>
	<li id="menu-item-824" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-824"><a href="https://ilovethepromise.com/theresa-2/">Theresa</a></li>
</ul>
</li>
<li id="menu-item-831" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-831"><a href="https://ilovethepromise.com/who-is-jesus/">WHO IS JESUS?</a></li>
<li id="menu-item-932" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-932"><a target="_blank" href="http://www.jaxcommunityevents.com"><span class="icon"></span>EVENTS</a></li>
<li id="menu-item-832" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-832"><a href="https://ilovethepromise.com/advertise/">ADVERTISE</a></li>
<li id="menu-item-833" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-833"><a href="https://ilovethepromise.com/contact/">CONTACT</a></li>
</ul></div><div id="so-mobilenav-mobile-1" data-id="1" class="so-mobilenav-mobile"></div><div class="menu-mobilenav-container"><ul id="mobile-nav-item-wrap-1" class="menu"><li><a href="#" class="mobilenav-main-link" data-id="1"><span class="mobile-nav-icon"></span>Menu</a></li></ul></div>			</div>
</nav><!-- .site-navigation .main-navigation -->

</header><!-- #masthead .site-header -->

	
	
	
	
	<div id="main" class="site-main">
		<div class="full-container">
			
<div id="primary" class="content-area">
	<div id="content" class="site-content" role="main">

	
		
<article id="post-1015" class="post post-1015 type-post status-publish format-standard has-post-thumbnail hentry category-uncategorized">

	<div class="entry-main">

		
					<header class="entry-header">

									<div class="entry-thumbnail"><img width="680" height="380" src="https://ilovethepromise.com/wp-content/uploads/2017/05/Romphim-680x380.png" class="attachment-vantage-thumbnail-no-sidebar size-vantage-thumbnail-no-sidebar wp-post-image" alt="" /></div>
				
									<h1 class="entry-title">For Father&#8217;s Day&#8230;.really?</h1>
				
									<div class="entry-meta">
						Posted on <a href="https://ilovethepromise.com/uncategorized/for-fathers-day-really/" title="8:59 pm" rel="bookmark"><time class="entry-date" datetime="2017-05-16T20:59:46+00:00">May 16, 2017</time></a><time class="updated" datetime="2017-05-16T20:59:46+00:00">May 16, 2017</time> <span class="byline"> by <span class="author vcard"><a class="url fn n" href="https://ilovethepromise.com/author/garywalsh/" title="View all posts by GaryWalsh" rel="author">GaryWalsh</a></span></span> 					</div><!-- .entry-meta -->
				
			</header><!-- .entry-header -->
		
		<div class="entry-content">
			<p>Dear Lord, please take me now&#8230;..I am a Father and appreciate whatever gift my children feel is best for me on Father&#8217;s Day&#8230;except for this.  First, I do not look anything like these young, flat-bellied, romper boys&#8230;and second&#8230;even if I did&#8230;you would NEVER catch me in one of these grown-man-onesies&#8230;.</p>
<p>&nbsp;</p>
<p><a href="https://www.kickstarter.com/projects/106904571/the-romphimtm-your-new-favorite-summer-outfit" target="_blank" rel="noopener noreferrer">More&#8230;if you can stand it&#8230;..</a></p>
					</div><!-- .entry-content -->

					<div class="entry-categories">
				Posted in <a href="https://ilovethepromise.com/category/uncategorized/" rel="category tag">Uncategorized</a>.			</div>
		
		

				<div id="fb-root"></div>
		<script type="text/javascript">
			(function(d, s, id) {
		  var js, fjs = d.getElementsByTagName(s)[0];
		  if (d.getElementById(id)) return;
		  js = d.createElement(s); js.id = id;
		  js.src = "//connect.facebook.net/en_GB/all.js#xfbml=1";
		  fjs.parentNode.insertBefore(js, fjs);
		}(document, 'script', 'facebook-jssdk'));
		</script>
				<script type="text/javascript">
			// Google Plus One
			(function () {
				var po = document.createElement( 'script' );
				po.type = 'text/javascript';
				po.async = true;
				po.src = 'https://apis.google.com/js/plusone.js';
				var s = document.getElementsByTagName( 'script' )[0];
				s.parentNode.insertBefore( po, s );
			})();
		</script>
				<script src="//platform.linkedin.com/in.js" type="text/javascript"> lang: en_US</script>
			<ul class="share-buttons">
		<li class="network facebook" style="width:25%">

			<div
				class="fb-like"
				data-href="https://ilovethepromise.com/uncategorized/for-fathers-day-really/"
				data-width="25"
				data-layout="button_count"
				data-send="false"
				data-height="21"
				data-show-faces="false"
				data-action="like"></div>
		</li>

		<li class="network twitter" style="width:25%">
						<iframe allowtransparency="true" frameborder="0" scrolling="no" src="https://platform.twitter.com/widgets/tweet_button.html?url=https://ilovethepromise.com/uncategorized/for-fathers-day-really/&amp;text=For Father&#8217;s Day&#8230;.really?&amp;related" style="height:20px;"></iframe>
		</li>

		<li class="network plusone" style="width:21%">
			<div class="g-plusone" data-size="medium" data-width="160"></div>
		</li>

		<li class="network linkedin" style="width:29%;">
			<script type="IN/Share" data-counter="right"></script>
		</li>
	</ul>
	
	</div>

</article><!-- #post-1015 -->
		

			<nav role="navigation" id="nav-below" class="site-navigation post-navigation">
		<h1 class="assistive-text">Post navigation</h1>

	
		<div class="single-nav-wrapper">
			<div class="nav-previous"><a href="https://ilovethepromise.com/uncategorized/california-pays-a-lot-for-recycling-only/" rel="prev"><span class="meta-nav">&larr;</span> California pays a lot for&hellip;</a></div>					</div>

	
	</nav><!-- #nav-below -->
	
					

	<div id="comments" class="comments-area">

	
	
	
		<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/uncategorized/for-fathers-day-really/#respond" style="display:none;">Cancel reply</a></small></h3>			<form action="https://ilovethepromise.com/wp-comments-post.php" method="post" id="commentform" class="comment-form">
				<p class="comment-notes"><span id="email-notes">Your email address will not be published.</span> Required fields are marked <span class="required">*</span></p><p class="comment-form-comment"><label for="comment">Comment</label> <textarea id="comment" name="comment" cols="45" rows="8" maxlength="65525" aria-required="true" required="required"></textarea></p><p class="comment-form-author"><label for="author">Name <span class="required">*</span></label> <input id="author" name="author" type="text" value="" size="30" maxlength="245" aria-required='true' required='required' /></p>
<p class="comment-form-email"><label for="email">Email <span class="required">*</span></label> <input id="email" name="email" type="text" value="" size="30" maxlength="100" aria-describedby="email-notes" aria-required='true' required='required' /></p>
<p class="comment-form-url"><label for="url">Website</label> <input id="url" name="url" type="text" value="" size="30" maxlength="200" /></p>
<p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='1015' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="8cf09aebff" /></p><p class="comment-subscription-form"><input type="checkbox" name="subscribe_comments" id="subscribe_comments" value="subscribe" style="width: auto; -moz-appearance: checkbox; -webkit-appearance: checkbox;" /> <label class="subscribe-label" id="subscribe-label" for="subscribe_comments">Notify me of follow-up comments by email.</label></p><p class="comment-subscription-form"><input type="checkbox" name="subscribe_blog" id="subscribe_blog" value="subscribe" style="width: auto; -moz-appearance: checkbox; -webkit-appearance: checkbox;" /> <label class="subscribe-label" id="subscribe-blog-label" for="subscribe_blog">Notify me of new posts by email.</label></p><p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="137"/></p>			</form>
			</div><!-- #respond -->
	
</div><!-- #comments .comments-area -->
		
	
	</div><!-- #content .site-content -->
</div><!-- #primary .content-area -->


<div id="secondary" class="widget-area" role="complementary">
			</div><!-- #secondary .widget-area -->

					</div><!-- .full-container -->
	</div><!-- #main .site-main -->

	
	
	<footer id="colophon" class="site-footer" role="contentinfo">

			<div id="footer-widgets" class="full-container">
					</div><!-- #footer-widgets -->
	
			<div id="site-info">
			<p style="text-align: center">Copyright <b>© </b>2017 <a href="http://cpbroadcasting.com">CP Broadcasting</a> |  <a href="http://www.cpbroadcasting.com/careers/">Careers</a>  |  <a href="http://www.cpbroadcasting.com/eeo/">EEO</a>  |  <a href="http://www.cpbroadcasting.com/privacy-policy/">Privacy</a>  |  <a href="http://www.cpbroadcasting.com/terms-and-conditions/">Terms and Conditions</a>  |  <a href="http://www.cpbroadcasting.com/contest-rules/">Contest Rules</a>  |  <a href="https://ilovethepromise.com/wp-admin/">ADMIN LOGIN</a></p>		</div><!-- #site-info -->
	
	
</footer><!-- #colophon .site-footer -->

	
</div><!-- #page-wrapper -->


<!-- Custom Facebook Feed JS -->
<script type="text/javascript">
var cfflinkhashtags = "true";
</script>
            <script type="text/javascript">
              (function() {
                var sa = document.createElement('script'); sa.type = 'text/javascript'; sa.async = true;
                sa.src = ('https:' == document.location.protocol ? 'https://cdn' : 'http://cdn') + '.ywxi.net/js/1.js';
                var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(sa, s);
              })();
            </script>	<div style="display:none">
	</div>
<a href="#" id="scroll-to-top" class="scroll-to-top" title="Back To Top"><span class="vantage-icon-arrow-up"></span></a><script type='text/javascript' src='https://ilovethepromise.com/wp-content/plugins/akismet/_inc/form.js?ver=3.3.2'></script>
<script type='text/javascript' src='https://ilovethepromise.com/wp-content/plugins/custom-facebook-feed/js/cff-scripts.js?ver=2.4.5'></script>
<script type='text/javascript' src='https://s0.wp.com/wp-content/js/devicepx-jetpack.js?ver=201720'></script>
<script type='text/javascript' src='https://ilovethepromise.com/wp-includes/js/comment-reply.min.js?ver=bb3be932eefd63a1ab9e576dfbee964a'></script>
<script type='text/javascript' src='https://ilovethepromise.com/wp-includes/js/wp-embed.min.js?ver=bb3be932eefd63a1ab9e576dfbee964a'></script>
<script type='text/javascript' src='https://stats.wp.com/e-201720.js' async defer></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:4.9',blog:'103845489',post:'1015',tz:'-4',srv:'ilovethepromise.com'} ]);
	_stq.push([ 'clickTrackerInit', '103845489', '1015' ]);
</script>

</body>
</html>
